Author Topic: Error msg with PMDX 407 board  (Read 1836 times)

Doddjn

  • Posts: 3
    • View Profile
Error msg with PMDX 407 board
« on: January 24, 2015, 02:34:35 PM »
After hooking up my Sherline (KBIC) DC motor controller, I get the following message. "Spindle speed capped by current range". Any ideas. Note the spindle turns on and off and when the spindle is on I get 6.6 volts between Aref and Agnd terminals on the 407 board. I have the Mach4 set on line 0 to min .05 and Max 1.00 in the config - spindle tab

Regards - John

Bob at PMDX

  • Administrator
  • Posts: 367
    • View Profile
    • PMDX
Re: Error msg with PMDX 407 board
« Reply #1 on: January 24, 2015, 11:24:28 PM »
After hooking up my Sherline (KBIC) DC motor controller, I get the following message. "Spindle speed capped by current range". Any ideas. Note the spindle turns on and off and when the spindle is on I get 6.6 volts between Aref and Agnd terminals on the 407 board. I have the Mach4 set on line 0 to min .05 and Max 1.00 in the config - spindle tab

That message is generated (by Mach4 - not our plug-in, FYI) when Mach4 sees an "S" command where the commanded speed is higher than the "max" value in the currently selected spindle speed range (in Mach3 this was called "Spindle Pulley Configuration").  Unless you have some script running that changes the spindle range selection, this is indeed "line 0" from the spindle configuration table (found by going to the Configure menu and selecting "Mach", then click on the "Spindle" tab).

The "min" and "max" values here are usually in RPM units, and while Mach4 accepts floating point values both here and in the "S" command, that is non-standard.  The standard calls for integer values.   I"m not sure why you have the range set to 0.05 to 1.0 unless you have a *VERY* slow spindle :-)  For that range, any "S" command with a value greater than 1.0 will generate the message that you saw.

I think you are seeing 6.6V on the PMDX-407's analog output because that is most likely the voltage coming out of the P3 terminal on the KBIC (the KBIC accepts a control voltage of 0-7 volts).  And since our plug-in sees the commanded spindle speed at the max value, it tries to drive the analog voltage to the reference.  Just to make sure, you should have the following connections between the KBIC and the PMDX-407:

KBIC   PMDX-407
P1       Agnd
P2       Aout
P3       Aref

So I think the best answer is to change the spindle "min" and "max" settings in Mach4 to match the actual spindle RPM range of your machine - which should also match the range of "S" values in your GCode files.  It may also be possible (but I do not recommend this as the "S" values would be non-standard) to keep your existing 0.05 to 1.0 spindle range and edit the "S" commands in your GCode file to be within that range.

Bob
Engineering Hell: Everything's right and nothing works.
Bob's Corollary: If everything's right and nothing works, double check your assumptions.

Doddjn

  • Posts: 3
    • View Profile
Re: Error msg with PMDX 407 board
« Reply #2 on: January 25, 2015, 11:42:28 AM »
It's a pity you spend your weekends answering questions like mine.

I could not get the spindle to respond to rpm when I was first testing - then made a an assumption that because the field was not integer that it was looking for %. Thanks much for the response and help. It is working now without the error.

Your support is great! Thank you for your help directly and the q&a from others on the forum.

Regards,

John