Author Topic: K1 relay not working  (Read 30 times)

onthemarc

  • Posts: 2
    • View Profile
K1 relay not working
« on: April 29, 2019, 07:54:42 AM »
I need help to get my K1 relay to work. I am trying to power my router on/off
I have a PMDX 126 BOB with ESS running Mach3
I'm not sure if the problem is in a mach3 setting or a BOB or ESS setting.
My CNC router is up and running so I assume my charge pump is working fine.
I have tried the following.
I am running in Jumbo mode. Dip switch settings
1-open
2-closed
3-closed
4-closed
5-open
6-open
7-closed
8-closed
JP1 and JP2 both in multimode.  I have 110volts to one side of K1 relay but no power out and no LED next to the relay.
Inn Mach 3 config (spindle setup) relay control: disable relay control is unchecked and M3 output#2
Config output signals:  outputt#2 enabled – port1 – pin 16 --active low (red X)
Mach 3 is adding M3 and M5 to the G-code  and I try the MDI input M3  I have “No Joy”
I have tried meany other settings without success.
What should I try next?
Thanks Onthemarc

12strings

  • Posts: 114
    • View Profile
Re: K1 relay not working
« Reply #1 on: May 01, 2019, 11:38:48 PM »
First - checking the most basic which I'm pretty sure you have correct or the 126 would be in test mode.  But just to make sure - DIP switch "open" is the switch pressed or slid away from the silkscreen that says "config 1", etc.  And "closed" is the switch pressed or slid towards the "config 1", etc., silkscreen.

When you issue an "M3", look at PMDX-126 connector J6 at the "16" pin.  Does the LED there turn on and off with M3 and M5 commands?  If so, try switching DIP switch 7 open and then closed again and see what happens.

If not, look in your Mach3 config and see if there is any other Mach output signal driving port 1 pin 16 (including the motor step/dir pins).

onthemarc

  • Posts: 2
    • View Profile
Re: K1 relay not working
« Reply #2 on: May 07, 2019, 02:10:38 AM »
I did have the spindle in motor config set to port 1 pin 16.
I turned that off and I heard the relay click.
tried M3  and nothing M5 and I had a light at J6 pin 16
I unchecked the active low and it works fine now
Thanks for your help

12strings

  • Posts: 114
    • View Profile
Re: K1 relay not working
« Reply #3 on: May 08, 2019, 12:18:28 AM »
Ahhhhh... to control the relay to turn the spindle on and off, you do NOT use the spindle motor on the "Motor Outputs" tab.  That is designed to be used when you have a stepper (or step servo) motor running the spindle.  Set all pins and ports on the "spindle" line to zeros.  Instead, you need to configure one of the general purpose outputs.  I haven't run Mach3 in quite a while, so this is from my very rusty memory:

On the spindle configuration tab in the upper left corner is something like "spindle control" or "relay control".  There is a check box to disable spindle relays (always seemed backwards to me), then two boxes that allow you to assign output numbers to "spindle forward" and "spindle reverse" (i.e. M3 and M4).  If you enter "1" in the box for "spindle forward, that means that output signal "Output #1" on the "Output Signals" tab will used to signal the router should be on and rotating "forward".

So... presuming you only want to turn the spindle on and off, not control direction, un-check the "disable spindle relays" box, set the "spindle forward" box to "1" and the "spindle reverse" box to "2" (or any number OTHER than "1").  Click on "Apply".

Next, go to the "Output signals" tab and scroll down to "Output #1".  Assign that to port 1 pin 16 with a red "X" in the "active low" (or "inverted" or whatever they call that column).  Then click on "apply" then "OK".

You should now be able to enter M3 and have the K2 relay energize and turn on your spindle.  M5 should de-energize K2 and turn off your router.