Author Topic: PMDX: No synchronized position from motion planner  (Read 110 times)

James

  • Posts: 6
    • View Profile
PMDX: No synchronized position from motion planner
« on: June 18, 2020, 08:14:38 PM »
hey guys, so i am running into a huge issue. i am using a windows 10 laptop with mach 4 (build 4300) and a pmdx 411 (Ver 0.53.263 plug in and ive tried the previous 4) i am attempting to use it with a cnc plasma cutter however about every 3rd ish probe it gives me a error "PMDX: No synchronized position from motion planner" and disable the machine, using a g31 code. if it try and allow mach4 plasma to handle the probe cycle with a m03 command i get a "mach 4 macro alarm 3 merror_not_now" i have tried adjusting the buffer settings and if i turn the g code buffer all the way down (to 100ms) it seems to have the best luck but it is just random. the plasma is off for all of this so it is not an electrical noise problem. i have uninstalled everything and re installed it about 7 times. i am in contact with mach support but no great ideas from them so far. the machiene runs fine with my linux computer. Im super bummed i just blew 300 bucks and a week of work to have it still running linuxcnc. sometimes mach4 will just stop (but not disable itself) also but that issue is on the back burner for now. i have emailed pmdx but not gotten any response in a week.