Author Topic: PMDX 422 issues  (Read 34 times)

airsiler

  • Posts: 3
    • View Profile
PMDX 422 issues
« on: July 28, 2020, 11:52:39 PM »
I just updated my MAch4 firmware 0.3 of this board and it says it downloaded firmware for version B. I am having issues with Z E stop in the + side saying its hit the E stop but it hasn't. Also my motor mapping isn't working now as well. On my Y I have motor 3 slaved to motor one and only motor one is working now.

These are the only things so far I have found but I am sure theres more. Any help would be nice.

Thanks Bill

12strings

  • Posts: 226
    • View Profile
Re: PMDX 422 issues
« Reply #1 on: July 29, 2020, 12:55:38 AM »
You say you "updated my Mach4 firmware 0.3".  Do you mean you updated the PMDX-SmartBOB plug-in (which also updates the SmartBOB firmware)?

And what do you mean by "0.3"?  Is that the SmartBOB plug-in version?  SmartBOB firmware version?  It doesn't sound like either of those as the latest plug-in version is 0.53.263, and the latest firmware version is 0.60.208.

The message about downloading firmware for "version B" means that the plug-in thinks you have a PMDX-422 version B or version C (I don't think they made a version D of the PMDX-422).  You can tell which version you have by looking on the bottom of the board.  Along one edge you will see some text like "PCB-519C" (that is what mine says).  The last letter is the board version.

With your PMX-422 connected to the USB port, start Mach4, then go to the "Configure" menu and select "Plugins", then select "PMDX SmartBOB".  Tell us what you see in the window that comes up.  It should give you a bunch of version numbers.

airsiler

  • Posts: 3
    • View Profile
Re: PMDX 422 issues
« Reply #2 on: July 29, 2020, 02:16:27 AM »
Ok when I look at the info under the Smart Bob I see the following. SmartBOB-USB Device: PMDX - 422 (RevB PCB) a Serial SN32325 (B1) this is on the board as well, PMDX SmartBob -USB Plugin version  0.53.263 and Firmware version 0.60.208. I just tried downgrading to Build 3481 as that's what they say the firmware had been tested to thinking that might be the issue. I couldn't find anything on the board that indicated the version, I am sure I am not looking in the right location. Prior to making the change to the new Software and updating the board firmware, the machine ran fine with a 6-year-old version. The update is the only thing that happened of late. One day working fine then the update and it's not working haha.

You say you "updated my Mach4 firmware 0.3".  Do you mean you updated the PMDX-SmartBOB plug-in (which also updates the SmartBOB firmware)?

And what do you mean by "0.3"?  Is that the SmartBOB plug-in version?  SmartBOB firmware version?  It doesn't sound like either of those as the latest plug-in version is 0.53.263, and the latest firmware version is 0.60.208.

The message about downloading firmware for "version B" means that the plug-in thinks you have a PMDX-422 version B or version C (I don't think they made a version D of the PMDX-422).  You can tell which version you have by looking on the bottom of the board.  Along one edge you will see some text like "PCB-519C" (that is what mine says).  The last letter is the board version.

With your PMX-422 connected to the USB port, start Mach4, then go to the "Configure" menu and select "Plugins", then select "PMDX SmartBOB".  Tell us what you see in the window that comes up.  It should give you a bunch of version numbers.

12strings

  • Posts: 226
    • View Profile
Re: PMDX 422 issues
« Reply #3 on: July 31, 2020, 12:32:28 AM »
It sounds like the update from the really old version of Mach4 somehow futzed your configuration.  Do you (hopefully) have a copy of your profile directory from before the update?  And do you remember what (6 year old) version of Mach4 you were running?  If you have your old profile (specifically the "Machine.ini" file) and your new, revised, not working profile, I may be able to help get the settings from the old one into the new one.

Or you can do this yourself.  Re-install the old Mach4 version IN A DIFFERENT DIRECTORY (i.e. not C:\Mach4Hobby) and put your old profile in the "Profiles" directory.  Run the Mach4GUI.exe from the directory in which you installed the old version.  Take a screen capture or write down all the settings from your motor tuning, axis mapping, inputs and outputs and spindle tabs.

Then run the current version of Mach4 and change the configuration to match what was shown in your old Mach4 version.

PMDX keeps a repository of old Mach4 releases in case you don't still have the installer for your old version.  You can find them here:
http://www.pmdx.com/Downloads_Mach4/Mach4_Hobby_Releases/

Now that I look at the old releases, if your previous Mach4 was 6 years old, that means it was a Mach4 version 1 release.  I seem to recall that things changed pretty significantly between version 1 and version 2 Mach4 releases.  That may be the issue, and the newer Mach4 versions can no longer convert the old INI files.

One more note: When/if you re-install the older version of Mach4, it may change your desktop icons to point to that older version.  To get the icons back to pointing to your new Mach4 install you may need to re-install the new Mach4 version (it is OK to install it on top of the existing install, as long as you aren't using "Mach4Mill" as your profile).

airsiler

  • Posts: 3
    • View Profile
Re: PMDX 422 issues
« Reply #4 on: July 31, 2020, 12:14:24 PM »
Thanks for spnding the time to respond. So I took Pictures of everything from my old profile before doing anything. I went through everything setting all motor configurations setting the motor mapping the same and the input signals all the same. This might of been a mistake as like you said a lot has changed sense the release I had before. This is what happens when you dont use things for over 6 years haha. I am going to download the manual for the new version of Mach4 and see if I can find anything. I did notice something else in the command line or history area when i try to move the Y axes this is the axes that I have motor 3 slave to motor 1 I get this (No Synchronizd position from motion planner) I am assuming this means its not talking to motor 3 on the slaved channel haha.

I also have Steve looking into this for me as well so I hope I can get this figured out soon as I cant use it right now.

Thanks once again for your help.

It sounds like the update from the really old version of Mach4 somehow futzed your configuration.  Do you (hopefully) have a copy of your profile directory from before the update?  And do you remember what (6 year old) version of Mach4 you were running?  If you have your old profile (specifically the "Machine.ini" file) and your new, revised, not working profile, I may be able to help get the settings from the old one into the new one.

Or you can do this yourself.  Re-install the old Mach4 version IN A DIFFERENT DIRECTORY (i.e. not C:\Mach4Hobby) and put your old profile in the "Profiles" directory.  Run the Mach4GUI.exe from the directory in which you installed the old version.  Take a screen capture or write down all the settings from your motor tuning, axis mapping, inputs and outputs and spindle tabs.

Then run the current version of Mach4 and change the configuration to match what was shown in your old Mach4 version.

PMDX keeps a repository of old Mach4 releases in case you don't still have the installer for your old version.  You can find them here:
http://www.pmdx.com/Downloads_Mach4/Mach4_Hobby_Releases/

Now that I look at the old releases, if your previous Mach4 was 6 years old, that means it was a Mach4 version 1 release.  I seem to recall that things changed pretty significantly between version 1 and version 2 Mach4 releases.  That may be the issue, and the newer Mach4 versions can no longer convert the old INI files.

One more note: When/if you re-install the older version of Mach4, it may change your desktop icons to point to that older version.  To get the icons back to pointing to your new Mach4 install you may need to re-install the new Mach4 version (it is OK to install it on top of the existing install, as long as you aren't using "Mach4Mill" as your profile).

12strings

  • Posts: 226
    • View Profile
Re: PMDX 422 issues
« Reply #5 on: July 31, 2020, 11:18:56 PM »
One more thing I just remembered.  I think the license file format changed from Mach4 version 1 to version 2.  So you may also need an updated/revised license file.  I'm sure Steve can help with that if it is needed.