Author Topic: PMDX-411 Mach4 G540 Unable to clear E-Stop  (Read 316 times)

billskeen63

  • Posts: 11
    • View Profile
PMDX-411 Mach4 G540 Unable to clear E-Stop
« on: December 16, 2018, 07:41:02 PM »
I was using Mach3 on an old Windows 7 machine, connected to G540, with real emergency stop button connected to pins 10 and 12/ground.

On new Windows 10, 64bit system, setup using latest versions of Mach4 v2 and drivers for PMDX 411, created new profile, selected PMDX-411 motion controller in Mach 4. Tried everything I know to clear the emergency stop with no joy. Then connected emergency stop to pin 1 on G540 and ground. Could now clear estop and enable.

Do I have to use 411 pin 10/G540 pin 1 for estop?


12strings

  • Posts: 123
    • View Profile
Re: PMDX-411 Mach4 G540 Unable to clear E-Stop
« Reply #1 on: December 18, 2018, 12:57:10 AM »
If you look near the end of the G540 manual you will see 3 tables: one that lists the pin-out of the DB25 connector, one for the DB9 motor connectors and one for the 12-pin screw terminal block.

Look on the DB25 table.  it shows that DB25 pin 15 is connected to the G540's EStop output.  So in Mach4 you need to map the EStop signal to the PMDX-411's "Pin15" input.  Then your actual EStop switch (normally closed) is wired to the screw terminal connector pins 10 and 12 (as listed in the 3rd table for the "Disable Input" and "Power Supply GND").

I don't recall if the G540's EStop output is active high or active low.  A little experimentation should tell you.  Bring up the SmartBOB's real-time display (under the Diagnostics menu, then select the SmartBOB, then click on the "real time display" button).  Look at the indicator under "Inputs" for "Pin 15".  On the G540 disconnect any wire from screw terminal pin 10.  This should put the G540 into a fault mode with its red LED turned on.  Now look at the PMDX real-time display for the "Pin15" signal.  If this is green, then the EStop is active  high.  If the indicator is red then the EStop input is active low.  Go in to the "Configure->Mach4->Input Signals" dialog and configure the EStop input accordingly.

billskeen63

  • Posts: 11
    • View Profile
Re: PMDX-411 Mach4 G540 Unable to clear E-Stop
« Reply #2 on: December 18, 2018, 09:00:48 AM »
Thanks 12strings. I appreciate you taking the time to respond.

As it is in most cases in using new h/w & s/w, it was a stupid user error.

I was changing the Input#15 on the Configure/Control/Inputs tab. I needed to scroll down to the E-Stop input and select SmartBobUSB pin 15. Figured it out when I looked carefully at my old Mach3.

The Pin10/EStop label on the SmartBob I/O status confused me too.


Mark3796

  • Posts: 5
    • View Profile
Re: PMDX-411 Mach4 G540 Unable to clear E-Stop
« Reply #3 on: June 01, 2019, 10:46:26 PM »
I'm having the same problem
Mach4 reports
E-stop is in effect! Clear the E-stop condition
My Gecko g540 DB 25 pin out table gives pin 15 as "Fault (input to PC) and the
Main Terminal block pin out has 10 Disable input (e-stop)

I can't seem to find the right combination in Mach4 to accept this.

12strings

  • Posts: 123
    • View Profile
Re: PMDX-411 Mach4 G540 Unable to clear E-Stop
« Reply #4 on: June 03, 2019, 10:47:11 PM »
First test:
1) start Mach4 with your PMDX-411 profile, then bring up the PMDX real-time display (Diagnostics menu, PMDX-SmartBOB, then click on "real time display").  For this step it does not matter how you have Mach4 configured other than having the PMDX-411 selected as the "motion device".

2) Turn on G540 and plug the PMDX-411 into the parallel port (if not already).

3) Place a jumper wire on the G540 between terminal block pins 10 and 12.  This should cause the G540 red LED to turn off.  Look at the Mach4 PMDX real-time display for pin 15.  The indicator should be green (I think).

4) Remove the jumper wire from the G540 terminal block pin 10.  The G540 red LED should turn on, and the real-time display for pin 15 should change to red (I think, if it was red before, it should now be green)

If you don't see that, there is a hardware issue between the PMDX-411 and the G540.

Second test:
1) In Mach4, in the configure, Mach4, Input Pins tab, configure the E-Stop input (NOTE: **NOT** "Input #15") to be PMDX-411 pin 15.  There should be a red "X" in the "active low" column. Click on OK to save any changed

2) With the wire still disconnected from the G540 terminal block pin 10, you should not be able to bring Mach4 out of EStop (cannot enable it).  I think you may see a message about EStop still active, or something like that.

3) Re-connect the wire on the G540 terminal block pin 10 to pin 12.

4) You should now be able to enable Mach4.

5) And if you again disconnect the wire from G540 terminal pin 10, mach4 should disable itself.