Author Topic: Motion Underrun error  (Read 346 times)

Noah Johnson

  • Posts: 1
    • View Profile
Motion Underrun error
« on: April 07, 2021, 01:22:31 PM »
I recently started getting this crippling "motion under run" error. I have actually had a lot of problems which may or may not be related. But lets take them one at a time.

This motion underrun error happens as soon as I start using the machine during jogging the machine.
The sequence is very repeatable.
1. start up Mach 4
2. home all axis
3. referencing completes without a problem
4. start jogging the machine. The first jog direction works no matter which one I pick. Second one is iffy... but if I go x+ then x- or y+ y- etc it stops and gives the error.

Slowing down the jogging rate has no effect even at 1%

Therefore I can't get to the point I can set a work offset and start milling.
I attached the debug log per the instructions in the FAQ.

my setup
Windows 10 Pro 64bit. All the specs match Mach 4 requirements.
PMDX 424



Other issues that have persisted since I first installed the PMDX 424. These may or may not help resolve the upper more urgent issue.

1. When I close Mach 4 by clicking the x in the corner, the window goes away but the app continues to run in the background. I usually find out when I go to open the app again and it says "Mach 4 is already running". I have to open the task manager and force close Mach 4. This happens about 7 out of 10 times when I close the app.  Its pretty annoying. I have begun to close Mach 4 then immediately open the task manager and "close" it again.
2. I frequently get this error PMDX: "No synchronized position from motion planner". If I click enable several times it goes away. Again I have a work around but it really sucks that is keeps happening.
3.  Another less frequent but regular error says Mach 4 can't communicate with the device. I have to close everything and disconnect the PMDX 424 and reconnect it. It starts working again.



Again the first issue is the most important as I have parts I can't run until we figure this out.

mntlvr

  • Posts: 11
    • View Profile
Re: Motion Underrun error
« Reply #1 on: July 02, 2021, 04:11:46 PM »

To Forum
I have much the same issue and I am using PDMX 416 board latest version of Mach 4 , Windows 10 Pro I am using a 36v dc 12 amp power supply for the H bridges. Power does not seem to be the problem have changed the H bridges and same results.
Hope there is a solution.

mntlvr

  • Posts: 11
    • View Profile
Re: Motion Underrun error
« Reply #2 on: August 13, 2021, 11:06:15 PM »
After talking with Steve the under Run error is a Mach 4 issue he has yet to find solution for best to bring this issue to Mach 4 forum and let them know about your issue.
Thanks